The Sharebite service disruption has been resolved, and Sharebite is now back online.
Resolved at: July 14, 2026 1:15 PM ET
Status: All services are operating normally.
If you continue to experience any issues, please contact us at help@sharebite.com so we can investigate right away. [You can also review current status updates at status.sharebite.com]
Thank you for your patience.
Resolved
The Sharebite service disruption has been resolved, and Sharebite is now back online.
Resolved at: July 14, 2026 1:15 PM ET
Status: All services are operating normally.
If you continue to experience any issues, please contact us at help@sharebite.com so we can investigate right away. [You can also review current status updates at status.sharebite.com]
Thank you for your patience.
Monitoring
An update on the ongoing Sharebite service disruption: we have rolled out a fix and the team is actively monitoring the situation.
Current impact: Users were experiencing significantly increased response times in the Passport App and delays when logging into the Sharebite platform. We identified the underlying issue and restored the impacted services. Performance has returned to near-normal levels, and all services are now operational.
What we’re doing: We are actively monitoring the platform to ensure all services continue to operate normally. While performance has improved significantly and response times have returned to near-normal levels, we will continue to monitor the platform closely to ensure stability.
Status: We’re currently monitoring for system stability.
We’ll share another update as soon as we have more information. For the latest status, please visit status.sharebite.com. If you need help in the meantime, contact us at help@sharebite.com.
Thank you for your patience.
Investigating
We’re currently experiencing a service disruption affecting Sharebite.
Current impact: Users cannot open the Passport App and there's delay in logging into the Sharebite platform
Status: Our team is actively investigating to identify the cause.
At this time, we do not have an estimated time for resolution. We will provide another update as soon as we know more.
If you need immediate assistance, contact us at help@sharebite.com.
Thank you for your patience.